I decided to go with a Cisco switch even though I have a Netgear 108E already. After trying to do a custom setup, on the Netgear I found the GUI to be clunky and cumbersome as it can get. So went ahead and configured my station's Cisco 2950 24 port for my AREDN setup(work in progress). I figured that there might be a lot of people that will not try a Cisco switch due to the CLI. So here is a "copy and paste" configuration to ease the pain.
There are 2940s on ebay going for $25, and I was just able to buy an 8 port 2960 for $40 shipped. I found the 2940 to be outdated for my taste but it still works for AREDN.
This configuration is for a 3 band hub site with one LAN port for each device and internet access to all 3 devices. It should work for any "fixed" interface Cisco switch, 2940, 2950, 2960, etc. If using a gigabit switch, or different port numbers on a 24 or 48 port switch, rename the interfaces accordingly.
-------------------Perform Factory Default------------------
enable
erase startup-config
delete flash:vlan.dat
reload
------------------At the initial prompt after the switch reboots "NO" --------------------
enable
conf terminal
vlan 2
name AREDN_DTD
vlan 9
name AREDN_900MHz_LAN
vlan 24
name AREDN_2.4GHz_LAN
vlan 58
name AREDN_5.8GHz_LAN
exit
hostname AREDN_SWITCH
interface FastEthernet0/1
description 900MHz_DEVICE
switchport trunk native vlan 9
switchport trunk allowed vlan 1,2,9
switchport mode trunk
no shut
interface FastEthernet0/2
description 900MHz_LAN_PORT
switchport access vlan 9
switchport mode access
spanning-tree portfast
no shut
interface FastEthernet0/3
description 2.4GHz_DEVICE
switchport trunk native vlan 24
switchport trunk allowed vlan 1,2,24
switchport mode trunk
no shut
interface FastEthernet0/4
description 2.4GHz_LAN_PORT
switchport access vlan 24
switchport mode access
spanning-tree portfast
no shut
interface FastEthernet0/5
description 5.8GHz_DEVICE
switchport trunk native vlan 58
switchport trunk allowed vlan 1,2,58
switchport mode trunk
no shut
interface FastEthernet0/6
description 5.8GHZ_LAN_PORT
switchport access vlan 58
switchport mode access
spanning-tree portfast
no shut
interface FastEthernet0/7
description SPARE_INTERNET_ACCESS_PORT
switchport access vlan 1
switchport mode access
spanning-tree portfast
no shut
interface FastEthernet0/8
description AREDN_INTERNET_ACCESS_PORT
switchport access vlan 1
switchport mode access
spanning-tree portfast
no shut
end
copy run start
Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer